summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej J.R. Hunt <andrzej@ahunt.org>2013-09-05 16:27:50 +0100
committerAndrzej J.R. Hunt <andrzej@ahunt.org>2013-11-07 01:05:55 -0600
commitf479f62c140bbab3869b8e2e783ee0c3f72dab3a (patch)
treeb6306eca52a912bb03158db05c669ffd48e63763 /configure.ac
parent628a812db0d9a53c1936874028c32c975153941d (diff)
Make libatomic_ops buildable and enable on non-X86.
Change-Id: Iec1d329f143ab76de7e8b4acd3da66efb6e0220c Reviewed-on: https://gerrit.libreoffice.org/5812 Reviewed-by: Andrzej J.R. Hunt <andrzej@ahunt.org> Tested-by: Andrzej J.R. Hunt <andrzej@ahunt.org> Reviewed-on: https://gerrit.libreoffice.org/6600
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 19 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 3fbfdcdb169e..b92cb4d22c16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8468,14 +8468,22 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
elif test "$cross_compiling" = "yes"; then
AC_MSG_RESULT([none])
else
- dnl ===================================================================
- dnl Check for system libatomic-ops
- dnl ===================================================================
- libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
- if test "$with_system_libatomic_ops" = "yes"; then
- SYSTEM_LIBATOMIC_OPS=YES
- AC_CHECK_HEADERS(atomic_ops.h, [],
- [AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
+ dnl We need libatomic-ops for any non X86/X64 system
+ if test "$CPU" != I -a "$CPU" != X; then
+ dnl ===================================================================
+ dnl Check for system libatomic-ops
+ dnl ===================================================================
+ libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
+ if test "$with_system_libatomic_ops" = "yes"; then
+ SYSTEM_LIBATOMIC_OPS=YES
+ AC_CHECK_HEADERS(atomic_ops.h, [],
+ [AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
+ else
+ SYSTEM_LIBATOMIC_OPS=NO
+ LIBATOMIC_OPS_CFLAGS="-I${WORKDIR}/UnpackedTarball/libatomic_ops/include"
+ LIBATOMIC_OPS_LIBS="-latomic_ops"
+ BUILD_TYPE="$BUILD_TYPE LIBATOMIC_OPS"
+ fi
fi
AC_MSG_RESULT([internal])
@@ -8489,6 +8497,9 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
fi
AC_SUBST(ENABLE_FIREBIRD_SDBC)
+AC_SUBST(SYSTEM_LIBATOMIC_OPS)
+AC_SUBST(LIBATOMIC_OPS_CFLAGS)
+AC_SUBST(LIBATOMIC_OPS_LIBS)
AC_SUBST(SYSTEM_FIREBIRD)
AC_SUBST(FIREBIRD_CFLAGS)
AC_SUBST(FIREBIRD_LIBS)