summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2021-11-07 19:46:18 +0100
committerLuboš Luňák <l.lunak@collabora.com>2021-11-08 09:15:11 +0100
commit033aea780cc8315979b6de2692f5f7aeb6a0e99b (patch)
tree741f529dc3578ad2a62e25eff118398eeabeec61 /configure.ac
parent69ee81cc3947a91efb03eb10a117a3f1de5b92ad (diff)
actually check for -isystem
When I added this in 151abb8b2b9d3a22229b98cec12e29484d1210 I made a copy&paste mistake that I corrected in a follow-up commit by removing the incorrect option without introducing -isystem into the check. Not that it matters in practice, apparently. Change-Id: I64d9ce34dcbaf9acdd8c794aed9fd84bae776d4a Reviewed-on: https://gerrit.libreoffice.org/c/core/+/124828 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6144dab8ba48..3cfcb7540e7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3766,7 +3766,7 @@ ISYSTEM=
if test "$GCC" = "yes"; then
AC_MSG_CHECKING( for -isystem )
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -isystem /usr/include -Werror"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ ISYSTEM="-isystem " ],[])
CFLAGS=$save_CFLAGS
if test -n "$ISYSTEM"; then