summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2021-08-20 14:31:36 +0100
committerCaolán McNamara <caolanm@redhat.com>2021-08-22 21:53:12 +0200
commit4250958a492b300a52a83e68dd599f9c36c5086e (patch)
tree3ac6239b36af193fec2f2264f622a00877c64ebc /configure.ac
parent054166821842de6f25c3123fcc1976b3c9d1d69b (diff)
ofz: prep for allowing oss-fuzz msan
dependencies need to be built with the msan flags so undo the --with-system .a usage now that trying to squeeze into the 12 hour build window isn't critical because the afl 6-8 hour build+check is disabled Change-Id: I3729d37e0f028c5efe62ce5d66ea6fe636d3d0c2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/120788 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a113ba458e60..ac226fd46ace 100644
--- a/configure.ac
+++ b/configure.ac
@@ -885,6 +885,9 @@ linux-gnu*|k*bsd*-gnu*)
build_skia=yes
test_gdb_index=yes
test_split_debug=yes
+ if test "$enable_fuzzers" = yes; then
+ test_system_freetype=no
+ fi
_os=Linux
;;
@@ -9012,7 +9015,11 @@ if test "$with_system_zlib" = "auto"; then
with_system_zlib="$with_system_libs"
;;
*)
- with_system_zlib=yes
+ if test "$enable_fuzzers" != "yes"; then
+ with_system_zlib=yes
+ else
+ with_system_zlib=no
+ fi
;;
esac
fi