summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-12-15 14:20:38 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-12-19 22:08:38 +0100
commit9663341f9249c739219ffe6cccf3762aa8dd78f3 (patch)
tree2b22177d01916abca8314b0834185892a8f77030 /configure.ac
parent00bc5a097313fbd003675267be961ad3a152ba42 (diff)
Bump --enable-compiler-plugins to Clang 3.8.0
<https://lists.freedesktop.org/archives/libreoffice/2017-December/079107.html> "Clang baseline bump" Change-Id: I18fca8794ea34118fc6308458064d0c28cf5caf7 Reviewed-on: https://gerrit.libreoffice.org/46557 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0689111ae700..4e00de777ec4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5921,8 +5921,7 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
- dnl Available in GCC 4.9 and at least in Clang 3.4 (which is the baseline
- dnl for at least --enable-compiler-plugins according to README.md):
+ dnl Available in GCC 4.9 and at least since Clang 3.4:
AC_MSG_CHECKING([whether $CXX supports __attribute__((warn_unused))])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
@@ -6419,6 +6418,13 @@ if test "$COM_IS_CLANG" = "TRUE"; then
else
compiler_plugins=no
fi
+ if test "$compiler_plugins" != no -a "$CLANGVER" -lt 30800; then
+ if test "$compiler_plugins" = yes; then
+ AC_MSG_ERROR([Clang $CLANGVER is too old to build compiler plugins; need >= 3.8.0.])
+ else
+ compiler_plugins=no
+ fi
+ fi
if test "$compiler_plugins" != "no"; then
dnl The prefix where Clang resides, override to where Clang resides if
dnl using a source build: