summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <michael.stahl@allotropia.de>2021-09-10 14:37:41 +0200
committerMichael Stahl <michael.stahl@allotropia.de>2021-11-01 18:14:17 +0100
commitb0e0fa1d2aee653586e1803bc30447b066e6cc66 (patch)
tree40b79d01ad55508a0d51a2ceb98538e2e02dc80c /configure.ac
parent1a3b3eda6ca1c8e063ba6db9e9f34f999ec92c49 (diff)
configure: add --with-webdav=curl
Change-Id: Id5cbeb9924b8e80b3b88f77fee2efd8457b5c302 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/122043 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cecc4993641f..a21c8ec9bc60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2398,7 +2398,7 @@ AC_ARG_WITH(system-liblangtag,
AC_ARG_WITH(webdav,
AS_HELP_STRING([--with-webdav],
[Specify which library to use for webdav implementation.
- Possible values: "neon", "serf", "no". The default value is "neon".
+ Possible values: "neon", "serf", "curl", "no". The default value is "neon".
Example: --with-webdav="serf"]))
AC_ARG_WITH(linker-hash-style,
@@ -10873,6 +10873,13 @@ fi
AC_MSG_CHECKING([for webdav library])
case "$WITH_WEBDAV" in
+curl)
+ AC_MSG_RESULT([curl])
+ # curl is already mandatory (almost) and checked elsewhere
+ if test "$enable_curl" = "no"; then
+ AC_MSG_ERROR(["--with-webdav=curl conflicts with --disable-curl"])
+ fi
+ ;;
serf)
AC_MSG_RESULT([serf])
# Check for system apr-util