summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXisco Fauli <xiscofauli@libreoffice.org>2022-08-17 12:59:51 +0200
committerXisco Fauli <xiscofauli@libreoffice.org>2022-08-18 10:10:18 +0200
commitdbfa68a56f087f06ac325a442c6cb0e99f3ecd53 (patch)
tree4892697f28fc224c6d89581a5e1252338c87c6d0 /configure.ac
parent633a175914f0ab960965aae7de04dc8d99edb33c (diff)
tdf#150452: Revert "tdf#130795 use concurrent hashmap in SharedStringPool"
This commit reverts 3749d9af3745c0eaff7239e379578e4e2af89e9d which removes the dependency on the external library cuckoo Without using cuckoo the same file in tdf#130795 takes real 0m4,892s user 0m5,298s sys 0m0,449s With it, it takes real 0m4,914s user 0m5,276s sys 0m0,444s pretty much the same time Change-Id: I4cc9000ac5bf26de22bb9835283ae8d5b3230196 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/138435 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk> Reviewed-by: Xisco Fauli <xiscofauli@libreoffice.org> Signed-off-by: Xisco Fauli <xiscofauli@libreoffice.org> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/138446
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 85521710e9a4..e375e590193f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2376,11 +2376,6 @@ AC_ARG_WITH(system-boost,
[Use boost already on system.]),,
[with_system_boost="$with_system_headers"])
-AC_ARG_WITH(system-cuckoo,
- AS_HELP_STRING([--with-system-cuckoo],
- [Use libcuckoo already on system.]),,
- [with_system_cuckoo="$with_system_headers"])
-
AC_ARG_WITH(system-glm,
AS_HELP_STRING([--with-system-glm],
[Use glm already on system.]),,
@@ -5609,7 +5604,6 @@ if test "$cross_compiling" = "yes"; then
BOOST
CAIRO
CLUCENE
- CUCKOO
CURL
DBCONNECTIVITY
DESKTOP
@@ -10421,26 +10415,6 @@ dnl ===================================================================
libo_CHECK_SYSTEM_MODULE([mdds], [MDDS], [mdds-2.0 >= 2.0.0], ["-I${WORKDIR}/UnpackedTarball/mdds/include"])
dnl ===================================================================
-dnl Check for system cuckoo
-dnl ===================================================================
-AC_MSG_CHECKING([which cuckoo to use])
-if test "$with_system_cuckoo" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_CUCKOO=TRUE
- AC_LANG_PUSH([C++])
- AC_CHECK_HEADER([libcuckoo/cuckoohash_map.hh], [],
- [AC_MSG_ERROR([libcuckoo/cuckoohash_map.hh not found. install cuckoo])], [])
- AC_LANG_POP([C++])
-else
- AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE CUCKOO"
- SYSTEM_CUCKOO=
- CUCKOO_CFLAGS="${ISYSTEM}${WORKDIR}/UnpackedTarball/cuckoo"
-fi
-AC_SUBST([CUCKOO_CFLAGS])
-AC_SUBST([SYSTEM_CUCKOO])
-
-dnl ===================================================================
dnl Check for system glm
dnl ===================================================================
AC_MSG_CHECKING([which glm to use])