summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2020-04-30 08:24:55 +0000
committerLuboš Luňák <l.lunak@collabora.com>2020-05-08 10:46:23 +0200
commit439ea553bef5a7e29ed20764ede1ae987e839bca (patch)
tree63ac49a855db9f14b88b988c472e668b69d8f374 /configure.ac
parentb23148333b26ecd91074516f788ee0718990b990 (diff)
hard-require Clang for Skia on Windows
Skia is the Windows default, and if Vulkan won't be available then Skia's raster mode will be used, which performs much worse when compiled using MSVC. https://lists.freedesktop.org/archives/libreoffice/2020-April/084929.html Change-Id: I6cd8b58f28ad6381d0cde1e834ca855c562dcd25 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93194 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 762e43987656..c53f15b5e08e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11170,9 +11170,13 @@ if test "$ENABLE_SKIA" = TRUE -a "$COM_IS_CLANG" != TRUE; then
fi
fi
if test -z "$CLANG_CC" -o -z "$CLANG_CXX"; then
- # So far do not require this, but release builds with Skia should possibly
- # do so.
- AC_MSG_WARN([Clang compiler not found.])
+ # Skia is the default on Windows, so hard-require Clang.
+ # Elsewhere it's used just by the 'gen' VCL backend which is rarely used.
+ if test "$_os" = "WINNT"; then
+ AC_MSG_ERROR([Clang compiler not found. The Skia library needs to be built using Clang.])
+ else
+ AC_MSG_WARN([Clang compiler not found.])
+ fi
else
save_CXX="$CXX"