summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-11-12 16:44:40 +0100
committerDavid Tardon <dtardon@redhat.com>2013-11-12 17:28:12 +0100
commit49a4d366ee7c298e547955344001f3d95622106a (patch)
tree650525471ff76e2f6fb3b86b4a5fb1f4135b2034 /configure.ac
parent1db1d9ecadf10788f5b310942e0128344ad2c8aa (diff)
integrate libeot
Change-Id: I0f28ff1680026d883909cc12efabb54f705cecb4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 817e4dae3052..e2a79bbaffd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1100,6 +1100,11 @@ AC_ARG_ENABLE(neon,
[Disable neon and the compilation of webdav binding.]),
,)
+AC_ARG_ENABLE([eot],
+ [AS_HELP_STRING([--enable-eot],
+ [Enable support for Embedded OpenType fonts.])],
+, [enable_eot=no])
+
AC_ARG_ENABLE(cve-tests,
AS_HELP_STRING([--disable-cve-tests],
[Prevent CVE tests to be executed]),
@@ -1479,6 +1484,11 @@ AC_ARG_WITH(system-expat,
[Use expat already on system.]),,
[with_system_expat="$with_system_libs"])
+AC_ARG_WITH(system-libeot,
+ AS_HELP_STRING([--with-system-libeot],
+ [Use libeot already on system.]),,
+ [with_system_libeot="$with_system_libs"])
+
AC_ARG_WITH(system-libxml,
AS_HELP_STRING([--with-system-libxml],
[Use libxml/libxslt already on system.]),,
@@ -7654,6 +7664,35 @@ else
fi
AC_SUBST(SYSTEM_EXPAT)
+AC_MSG_CHECKING([whether to enable Embedded OpenType support])
+if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_eot" = "yes"; then
+ ENABLE_EOT="TRUE"
+ AC_DEFINE([ENABLE_EOT])
+ AC_MSG_RESULT([yes])
+
+ AC_MSG_CHECKING([which libeot to use])
+ if test "$with_system_libeot" = "yes"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_LIBEOT=YES
+ AC_CHECK_HEADER([libeot.h], [],
+ [AC_MSG_ERROR([libeot.h not found. install libeot])], [])
+ AC_CHECK_LIB([libeot], [eot2ttf_file], [:],
+ [AC_MSG_RESULT([libeot library not found or functional.])], [])
+ libo_MINGW_CHECK_DLL([libeot])
+ else
+ AC_MSG_RESULT([internal])
+ SYSTEM_LIBEOT=NO
+ BUILD_TYPE="$BUILD_TYPE LIBEOT"
+ fi
+else
+ ENABLE_EOT=
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST([ENABLE_EOT])
+AC_SUBST([SYSTEM_LIBEOT])
+AC_SUBST([LIBEOT_CFLAGS])
+AC_SUBST([LIBEOT_LIBS])
+
dnl ===================================================================
dnl Check for system libebook
dnl ===================================================================