summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <atimar@suse.com>2013-01-24 10:50:26 +0100
committerAndras Timar <atimar@suse.com>2013-01-24 10:52:48 +0100
commit535006f3657feb2a64b50fb879e73294ab726852 (patch)
treea3123cfb777f8628d8330d1efc42392625b92a37 /configure.ac
parent1b375d580fb32739cc3b6625400337fa7380cdab (diff)
fix MSM name for x64 in the VC90 case
Change-Id: I69ff4f69e3ef93ed36cdcda9c54513624e8c98d0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 13 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d8ef0d5cf9be..dc13c159b07d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4962,21 +4962,27 @@ find_msms()
if test -e $msmdir/policy_9_0_Microsoft_VC90_CRT_x86.msm; then
msms="$msms policy_9_0_Microsoft_VC90_CRT_x86.msm"
else
- AC_MSG_ERROR([Merge modules not found])
+ AC_MSG_ERROR([Merge module policy_9_0_Microsoft_VC90_CRT_x86.msm not found])
fi
fi
if test "$BUILD_X64" = TRUE; then
- if test -e $msmdir/Microsoft_VC${VCVER}_CRT_x64.msm; then
- msms="$msms Microsoft_VC${VCVER}_CRT_x64.msm"
- else
- AC_MSG_ERROR([Failed to copy x64 merge modules])
- fi
if test "$VCVER" = "90"; then
if test -e $msmdir/policy_9_0_Microsoft_VC90_CRT_x86_x64.msm; then
msms="$msms policy_9_0_Microsoft_VC90_CRT_x86_x64.msm"
else
- AC_MSG_ERROR([Merge modules not found])
+ AC_MSG_ERROR([Merge module policy_9_0_Microsoft_VC90_CRT_x86_x64.msm not found])
+ fi
+ if test -e $msmdir/Microsoft_VC90_CRT_x86_x64.msm; then
+ msms="$msms Microsoft_VC90_CRT_x86_x64.msm"
+ else
+ AC_MSG_ERROR([Merge module Microsoft_VC90_CRT_x86_x64.msm not found])
+ fi
+ else
+ if test -e $msmdir/Microsoft_VC${VCVER}_CRT_x64.msm; then
+ msms="$msms Microsoft_VC${VCVER}_CRT_x64.msm"
+ else
+ AC_MSG_ERROR([Merge module Microsoft_VC${VCVER}_CRT_x64.msm not found])
fi
fi
fi