summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2013-07-29 15:58:43 +0200
committerFridrich Strba <fridrich@documentfoundation.org>2013-07-30 13:25:15 +0000
commit9accbedad3648dca197439a8cc39c268cf34ea99 (patch)
tree81bf9ef42bfd908f50ea7092189e1535cbbde137 /configure.ac
parent7afc29809ec9db8c5064d5b5857f64db9bd843be (diff)
Drop internal copies of X11 extensions headers
They are not use by default since 2011, and non of the distro configs uses --without-system-xextensions-headers. Change-Id: I51e88796c22b1b3d0854c3ec1db15fcab720a079 Reviewed-on: https://gerrit.libreoffice.org/5175 Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org> Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 8 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 562d463e20c8..b4f7084dd6cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1624,13 +1624,6 @@ AC_ARG_WITH(system-bluez,
[Use bluetooth.h already on system.]),,
[with_system_bluez="$with_system_headers"])
-AC_ARG_WITH(system-xextensions-headers,
- AS_HELP_STRING([--with-system-xextensions-headers],
- [To build without system X11 extensions headers, use
- --without-system-xextensions-headers. This is possibly
- useful on legacy unix systems which ship with the libs
- but without the headers.]))
-
AC_ARG_WITH(system-mesa-headers,
AS_HELP_STRING([--with-system-mesa-headers],
[Use Mesa headers already on system.]),,
@@ -8807,16 +8800,8 @@ if test "$WANT_X11" = "yes"; then
dnl ===================================================================
dnl Check for extension headers
dnl ===================================================================
- AC_MSG_CHECKING([whether to use internal X11 extensions headers])
- if test "$with_system_xextensions_headers" != "no"; then
- AC_MSG_RESULT([no])
- AC_CHECK_HEADERS(X11/extensions/shape.h,[],[AC_MSG_ERROR([libXext headers not found])],
- [#include <X11/extensions/shape.h>])
- else
- AC_MSG_RESULT([yes])
- BUILD_TYPE="$BUILD_TYPE X11_EXTENSIONS"
- fi
-
+ AC_CHECK_HEADERS(X11/extensions/shape.h,[],[AC_MSG_ERROR([libXext headers not found])],
+ [#include <X11/extensions/shape.h>])
fi
dnl ===================================================================
@@ -8829,14 +8814,8 @@ if test "$WANT_X11" = "yes" -a "$test_xrender" = "yes"; then
XRENDER_CFLAGS=$(printf '%s' "$XRENDER_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
AC_CHECK_LIB([Xrender], [XRenderQueryVersion], [:],
[AC_MSG_ERROR(libXrender not found or functional)], [])
- AC_MSG_CHECKING([which Xrender headers to use])
- if test "$with_system_xextensions_headers" != "no"; then
- AC_MSG_RESULT([external])
- AC_CHECK_HEADER(X11/extensions/Xrender.h, [],
- [AC_MSG_ERROR(Xrender not found. install X)], [])
- else
- AC_MSG_RESULT([internal])
- fi
+ AC_CHECK_HEADER(X11/extensions/Xrender.h, [],
+ [AC_MSG_ERROR(Xrender not found. install X)], [])
else
AC_MSG_RESULT([no])
fi
@@ -11380,18 +11359,16 @@ if test "$test_cairo" = "yes"; then
CAIRO_CFLAGS=$(printf '%s' "$CAIRO_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
if test "$test_xrender" = "yes"; then
- if test "$with_system_xextensions_headers" != "no"; then
- AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
- AC_LANG_PUSH([C])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <X11/extensions/Xrender.h>]],[[
+ AC_MSG_CHECKING([whether Xrender.h defines PictStandardA8])
+ AC_LANG_PUSH([C])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <X11/extensions/Xrender.h>]],[[
#ifdef PictStandardA8
#else
return fail;
#endif
]])],[AC_MSG_RESULT([yes])],[AC_MSG_ERROR([no, X headers too old.])])
- AC_LANG_POP([C])
- fi
+ AC_LANG_POP([C])
fi
libo_MINGW_CHECK_DLL([libcairo])
libo_MINGW_TRY_DLL([libfontconfig])