summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2013-08-29 08:51:01 +0200
committerStephan Bergmann <sbergman@redhat.com>2013-08-29 08:51:01 +0200
commit9fed8a5e4a4c45d6a08260e9480ca6b43254b120 (patch)
tree164c2fe4501d94e73ff1f2e283b3ac19b646874d /configure.ac
parent0c7e4656702a2e9e90cbb9e12f0bfeccafc472a6 (diff)
Do not silently ignore --enable-libc++
Change-Id: Ifbabb338739ae452bee6cac73e4b2046356a4d17
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c8ae2d64a199..bda7c01a2c97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2670,6 +2670,9 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what compiler to use])
case $with_macosx_sdk in
10.6)
+ if test "$enable_libc__" = yes; then
+ AC_MSG_ERROR([--enable-libc++ requires --with-macosx-version-min-required >= 10.7])
+ fi
# did someone copy her 10.6 sdk into xcode 4 (needed on Mountain Lion)?
if test "$(echo $MACOSX_SDK_PATH | cut -c1-23)" = "/Applications/Xcode.app"; then
CC="`xcrun -find gcc` $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
@@ -2682,7 +2685,10 @@ if test $_os = Darwin; then
LIBTOOL=libtool
;;
10.7|10.8|10.9)
- if test "$enable_libc__" = yes -a "$with_macosx_version_min_required" != 10.6; then
+ if test "$enable_libc__" = yes; then
+ if test "$with_macosx_version_min_required" = 10.6; then
+ AC_MSG_ERROR([--enable-libc++ requires --with-macosx-version-min-required >= 10.7])
+ fi
# Use libc++ instead of libstdc++ when possible
# and also compile as C++11
stdlib="-std=c++11 -stdlib=libc++"