summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-14 21:20:33 +0200
committerTomaž Vajngerl <tomaz.vajngerl@collabora.com>2015-10-15 10:28:29 +0200
commita8b15cf6dde500235c84dbeb3769e2385512e2b8 (patch)
treea29b45f0124d61867d34ac999443c914c2d0471a /configure.ac
parentd6dcc38235c665039752379f4d7fdc3933de4a09 (diff)
allow using Android Studio with lldb to debug native part
and of course also for the Java part Using build-id linker flag allows lldb to map the installed .so to the non-stripped version on the buildhost. Also ndk-gdb supports specifying a different package name on the commandline, so no need for the error in configure anymore. Change-Id: If6887a27cc8ab15ee6ab612502cacf0a22ade737 (cherry picked from commit 8840a66faceb5ebff2e6021e9b14da691d420234)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 0 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 51a70a8879dc..8423fb416915 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12483,10 +12483,6 @@ if echo "$host_os" | grep -q linux-android ; then
AC_MSG_RESULT([not set, using $ANDROID_PACKAGE_NAME])
else
- if test -n "$ENABLE_DEBUG" -a "$with_android_package_name" != "org.libreoffice" ; then
- AC_MSG_ERROR([The package name must be set
-to org.libreoffice when debugging, please avoid --with-android-package-name.])
- fi
ANDROID_PACKAGE_NAME="$with_android_package_name"
AC_MSG_RESULT([$ANDROID_PACKAGE_NAME])
fi