summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2022-02-24 17:37:26 +0100
committerStephan Bergmann <sbergman@redhat.com>2022-02-25 13:45:38 +0100
commitb1d500e8a4eadb72d0e574f77ebf33fbc5701900 (patch)
tree78907f7f5bec943a3cb717dc28a72e4eb50b735e /configure.ac
parentaa95913dd8e505123ba8974d5de27ac0ec928cce (diff)
Drop support for $host_os = 'macos*', in addition to 'darwin*'
...which had originally been added with baab4f890c8ac99d1b8dab5790fbb7ab949100ab "Initial WIP steps for building for macOS on Apple Silicon" for unclear reasons (just stating "use 'darwin' (or 'macos')" in the commit message), and then further improved with 5a0991c9cd60b6ab10fe0665511e7749a0c0ecc2 "mac: allow cross compiling with host/build x86_64-apple-macos". But it turns out that manually specifying --host or --build =...-macos rather than =...-darwin has issues as discussed in the comments at <https://gerrit.libreoffice.org/c/core/+/130353> "icu: override platform flags for MacOS build", and which can hopefully be avoided by not allowing =...-macos in the first place, and rather forcing people to specify =...-darwin. Change-Id: Ib100b7270250083eba4146430e967073a8cbca46 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/130505 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 4 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index f7ba69d78d9e..accb60493657 100644
--- a/configure.ac
+++ b/configure.ac
@@ -956,7 +956,7 @@ cygwin*|wsl*)
fi
;;
-darwin*|macos*) # macOS
+darwin*) # macOS
using_freetype_fontconfig=no
using_x11=no
build_skia=yes
@@ -982,14 +982,6 @@ darwin*|macos*) # macOS
LINKFLAGSNOUNDEFS=""
case "$host_cpu" in
aarch64|arm64)
- case "$host_os" in
- macos*)
- # HOST_PLATFORM is used for external projects and their configury occasionally doesn't like
- # the "macos" part so be sure to use aarch64-apple-darwin for now.
- HOST_PLATFORM=aarch64-apple-darwin
- ;;
- esac
-
# Apple's Clang uses "arm64"
host_cpu_for_clang=arm64
esac
@@ -4933,7 +4925,7 @@ cygwin*|wsl*)
# Already handled
;;
-darwin*|macos*)
+darwin*)
COM=GCC
OS=MACOSX
RTL_OS=MacOSX
@@ -8844,7 +8836,7 @@ if test -n "$ENABLE_JAVA" -a -z "$JAVAINC"; then
JAVAINC="$JAVAINC -I$JAVA_HOME/include"
;;
- darwin*|macos*)
+ darwin*)
if test -d "$JAVA_HOME/include/darwin"; then
JAVAINC="-I$JAVA_HOME/include -I$JAVA_HOME/include/darwin"
else
@@ -11536,7 +11528,7 @@ elif $GNUCP --version 2>/dev/null | grep "GNU fileutils" >/dev/null 2>/dev/null;
AC_MSG_RESULT([yes])
else
case "$build_os" in
- darwin*|macos*|netbsd*|openbsd*|freebsd*|dragonfly*|aix*)
+ darwin*|netbsd*|openbsd*|freebsd*|dragonfly*|aix*)
x_GNUCP=[\#]
GNUCP=''
AC_MSG_RESULT([no gnucp found - using the system's cp command])