summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2013-08-28 16:09:39 +0200
committerPetr Mladek <pmladek@suse.cz>2013-08-28 16:09:39 +0200
commitb70d4ad13b909265c54a9ff55f07224a14e9feb2 (patch)
tree00c7f8b786e2314225e44d8cbc49c98dcfd0486f /configure.ac
parentc656482c5a1467d6dc21601e1296ba3711916d6b (diff)
add --with-help=common parameter to the configure option
It allows to build only the common parts of the help, e.g. bundle the helpcontent-related icons. It is useful when the build content is built separately. For example, it is used to speed up the build of the main package in openSUSE Build Service.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 20 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8dcdcd1cad23..c8ae2d64a199 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1701,7 +1701,16 @@ AC_ARG_WITH(jdk-home,
AC_ARG_WITH(help,
AS_HELP_STRING([--with-help],
- [Enable the build of help.]))
+ [Enable the build of help. There is a special parameter "common" that
+ can be used to bundle only the common part, .e.g help-specific icons.
+ This is useful when you build the helpcontent separately.])
+ [
+ Usage: --with-help build the entire local help
+ --without-help no local help (default)
+ --with-help=common bundle common files for the local
+ help but do not build the whole help
+ ],
+,)
AC_ARG_WITH(java,
AS_HELP_STRING([--with-java],
@@ -4623,14 +4632,21 @@ fi
AC_SUBST(DO_FETCH_TARBALLS)
AC_MSG_CHECKING([whether to build help])
-if test "$with_help" = "yes" -a $_os != iOS -a $_os != Android; then
- AC_MSG_RESULT([yes])
+HELP_COMMON_ONLY=FALSE
+if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Android; then
BUILD_TYPE="$BUILD_TYPE HELP"
- SCPDEFS="$SCPDEFS -DWITH_HELP"
GIT_NEEDED_SUBMODULES="helpcontent2 $GIT_NEEDED_SUBMODULES"
+ if test "$with_help" = "common" ; then
+ HELP_COMMON_ONLY=TRUE
+ AC_MSG_RESULT([common only])
+ else
+ SCPDEFS="$SCPDEFS -DWITH_HELP"
+ AC_MSG_RESULT([yes])
+ fi
else
AC_MSG_RESULT([no])
fi
+AC_SUBST(HELP_COMMON_ONLY)
dnl Test whether to include MySpell dictionaries
dnl ===================================================================