summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-08-15 13:25:22 +0200
committerAndras Timar <andras.timar@collabora.com>2014-08-20 01:16:43 -0500
commitba754e8ba8897be196de48c48df63b9671115356 (patch)
treecb83f863ae3c868994c6bc947569ee4136abac0c /configure.ac
parent14bdff6f667ab28e14618fcb3dfb83bf2c2c765f (diff)
configure: don't try to use Win32 make on release branch
Change-Id: Icd8c1b45659ca323aef25a55803f5b1ce078b9d3 Reviewed-on: https://gerrit.libreoffice.org/10932 Reviewed-by: Thomas Arnhold <thomas@arnhold.org> Tested-by: Thomas Arnhold <thomas@arnhold.org> (cherry picked from commit 2087b54aab25ddbab5128af9f777b1686bc0ce5e) Reviewed-on: https://gerrit.libreoffice.org/10990 Reviewed-by: Andras Timar <andras.timar@collabora.com> Tested-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 312eacd0f8aa..2560a0d06c93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4798,8 +4798,18 @@ for a in "$MAKE" "$GNUMAKE" make gmake gnumake; do
if test -n "$a"; then
$a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
if test $? -eq 0; then
- GNUMAKE=`which $a`
- break
+ if test "$build_os" = "cygwin"; then
+ if test -n "$($a -v | grep 'Built for Windows')" ; then
+ AC_MSG_NOTICE([$a is a native Win32 make, which is not supported on this old branch.])
+ unset GNUMAKE
+ else
+ GNUMAKE=`which $a`
+ break
+ fi
+ else
+ GNUMAKE=`which $a`
+ break
+ fi
fi
fi
done