summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-07-29 10:11:06 +0300
committerTor Lillqvist <tml@iki.fi>2013-07-29 10:11:06 +0300
commitbd8d3ac6666137eacf63d7eda4441392c9783b6f (patch)
treef8410504d45f6068065e12e62f41222a252ac0d6 /configure.ac
parenta95d1eff071cfafb7e072f6ba82fd04989a76ea9 (diff)
Accept NDK r9
Change-Id: Ie7368d0995653d7051b3c67d4b7667e68787da8a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ee8a35d969ff..f60785de2c6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,10 +161,10 @@ if test -n "$with_android_ndk"; then
ANDROID_NDK_VERSION=`cut -f1 -d' ' <$ANDROID_NDK_HOME/RELEASE.TXT`
case $ANDROID_NDK_VERSION in
- r8*)
+ r8*|r9)
;;
*)
- AC_MSG_ERROR([Unsupported NDK version $ANDROID_NDK_VERSION, only r8* versions are supported])
+ AC_MSG_ERROR([Unsupported NDK version $ANDROID_NDK_VERSION, only r8* and r9 versions are supported])
;;
esac
@@ -201,12 +201,12 @@ if test -n "$with_android_ndk"; then
fi
# Check if there is a 64-bit tool-chain. Google provides a NDK with 64-bit tool-chain binaries in
- # NDK r8e, and for earlier NDKs it was possible to build one yourself. Using a 64-bit linker is
- # required if you compile large parts of the code with -g. A 32-bit linker just won't manage to
- # link the (app-specific) single huge .so that is built for the apps in android/experimental/* if
- # there is debug information in a significant part of the object files. (A 64-bit ld.gold grows to
- # much over 10 gigabytes of virtual space when linking such a .so if all objects have been built
- # with debug information.)
+ # NDK r8e and later, and for earlier NDKs it was possible to build one yourself. Using a 64-bit
+ # linker is required if you compile large parts of the code with -g. A 32-bit linker just won't
+ # manage to link the (app-specific) single huge .so that is built for the apps in
+ # android/experimental/* if there is debug information in a significant part of the object files.
+ # (A 64-bit ld.gold grows to much over 10 gigabytes of virtual space when linking such a .so if
+ # all objects have been built with debug information.)
toolchain_system='*'
if test $build_os = linux-gnu; then
ANDROID_COMPILER_BIN=$ANDROID_COMPILER_DIR/prebuilt/linux-x86/bin