summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-01-31 20:44:25 +0200
committerTor Lillqvist <tml@iki.fi>2013-01-31 21:43:59 +0200
commitc5b1441ede3c58f1fe92372cbb48864f9d4df6ec (patch)
treec86b771e67121fe3ff1711f403bd633c02e93ec4 /configure.ac
parent0e63a97066a817f3d01b40d99e3e1ed831ae3598 (diff)
Use separate config_*.h files for BUILD and HOST when cross-compiling
We have only been lucky so far that there hasn't been any compilation errors caused by using the HOST platform config_*.h files also for the BUILD platform. But as more and more information found out during configury is stored in config_*.h files, sooner or later it will be a problem. Move config/* to config_host/*. When not cross-compiling, the config_*.h files in config_host expanded from config_*.h.in are all there is. When cross-compiling, the generated config_*.h files for the BUILD platform are put into a config_build folder. Then use config_build when building the cross_toolset and config_host otherwise. Change-Id: I3c28cc83866bffd696b45d00dfb68e00bc2ae538
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index a707d4a88b29..b2f7d5c4bdef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4114,7 +4114,7 @@ if test "$cross_compiling" = "yes"; then
config_host.mk.in \
configure \
Makefile.in \
- config/config_*.h.in \
+ config_host/config_*.h.in \
bin/get_config_variables \
solenv/bin/getcompver.awk \
solenv/inc/langlist.mk \
@@ -4170,6 +4170,8 @@ if test "$cross_compiling" = "yes"; then
test -f ./config_host.mk 2>/dev/null || exit
cp config_host.mk ../config_build.mk
cp config.log ../config.Build.log
+ mkdir -p ../config_build
+ cp config_host/*.h ../config_build
. ./bin/get_config_variables COM GUI OS PATH CPU CPUNAME CC CXX DISABLE_PYTHON MACOSX_DEPLOYMENT_TARGET INPATH OUTPATH PYTHON SYSTEM_LIBXSLT OUTDIR SOLARINC SOLARLIB WORKDIR
for V in COM GUI OS CPU CPUNAME CC CXX DISABLE_PYTHON MACOSX_DEPLOYMENT_TARGET INPATH OUTPATH \
@@ -12308,12 +12310,12 @@ else
fi
AC_CONFIG_FILES([config_host.mk Makefile solenv/inc/minor.mk instsetoo_native/util/openoffice.lst])
-AC_CONFIG_HEADERS([config/config_clang.h])
-AC_CONFIG_HEADERS([config/config_global.h])
-AC_CONFIG_HEADERS([config/config_graphite.h])
-AC_CONFIG_HEADERS([config/config_telepathy.h])
-AC_CONFIG_HEADERS([config/config_vclplug.h])
-AC_CONFIG_HEADERS([config/config_version.h])
+AC_CONFIG_HEADERS([config_host/config_clang.h])
+AC_CONFIG_HEADERS([config_host/config_global.h])
+AC_CONFIG_HEADERS([config_host/config_graphite.h])
+AC_CONFIG_HEADERS([config_host/config_telepathy.h])
+AC_CONFIG_HEADERS([config_host/config_vclplug.h])
+AC_CONFIG_HEADERS([config_host/config_version.h])
AC_OUTPUT
# touch the config timestamp file