summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-08-13 10:39:00 +0200
committerMichael Stahl <Michael.Stahl@cib.de>2019-08-13 11:42:15 +0200
commitc78dd0a726b32d922a0d75a26a51d4c30612368c (patch)
tree455bbae226ad96aca1d5cf5defd4858166c28575 /configure.ac
parent23cf31c175f1c60da89c6594c5db25dddaaa57d5 (diff)
configure: don't enable export validation if there are no schemas
Schemas are excluded from tarballs since commit 34dced99c33a97dab86c4538fa267ad4ad4fb41f because of the license. Change-Id: I6540926d9ebb390d7956bbd1df3bb915adebb64b Reviewed-on: https://gerrit.libreoffice.org/77383 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1aeaa6184eb6..b2b61a80a3c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7661,6 +7661,12 @@ if test "$with_export_validation" != "no"; then
else
AC_MSG_RESULT([no, as Java is too old, need Java 8])
fi
+ elif ! test -d "${SRC_ROOT}/schema"; then
+ if test "$with_export_validation" = "yes"; then
+ AC_MSG_ERROR([requested, but schema directory is missing (it is excluded from tarballs)])
+ else
+ AC_MSG_RESULT([no, schema directory is missing (it is excluded from tarballs)])
+ fi
else
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_EXPORT_VALIDATION)