summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2013-08-29 14:50:58 +0200
committerPetr Mladek <pmladek@suse.cz>2013-08-29 14:55:40 +0200
commitd9b62a48d75e596888fcf10f5f73fed93e7b88a3 (patch)
tree85efa52e905b40f9b751070e6ed58c695d2e7390 /configure.ac
parent74d4f612af484735fae9c48b9cd7e609dab7fe64 (diff)
Allow to set EXTRA_BUILDID also via environment variable (fdo#58034)
This is much easier with tinderboxed that work with static autogen.input Change-Id: Ifb0b7884bbad14a286023b3dbd7d1d2a12f36787
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8647bdd72f5d..682d5dd2569b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12107,10 +12107,12 @@ AC_SUBST(PROGRESSTEXTCOLOR)
AC_SUBST(PROGRESSTEXTBASELINE)
-EXTRA_BUILDID=
AC_MSG_CHECKING([for extra build ID])
if test -n "$with_extra_buildid" -a "$with_extra_buildid" != "yes" ; then
EXTRA_BUILDID="$with_extra_buildid"
+fi
+# in tinderboxes, it is easier to set EXTRA_BUILDID via the environment variable instead of configure switch
+if test -n "$EXTRA_BUILDID" ; then
AC_MSG_RESULT([$EXTRA_BUILDID])
else
AC_MSG_RESULT([not set])