summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-09-09 20:03:22 +0200
committerStephan Bergmann <sbergman@redhat.com>2020-09-09 21:28:34 +0200
commit619d518014b7998dc40288b1276ecd49f678ada9 (patch)
tree79bb42121f90220317f54abdb047359ed8a28e31 /configure.ac
parent4a6fedc2e21d7036ae784ed90e78e3eb2fe1b3d5 (diff)
Fix AC_RUN_IFELSE for cross-compilation builds
Regression introduced with ad6ef813e9d745d44719dae381d64cdcc2f82719 "Guard against some GCC consteval bug". Change-Id: Ie2853b0b391425faf0ae6a956c56df3002ee73bb Reviewed-on: https://gerrit.libreoffice.org/c/core/+/102333 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bfa0d28e5969..eec433754275 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6819,7 +6819,7 @@ AC_RUN_IFELSE([AC_LANG_PROGRAM([
])], [
AC_DEFINE([HAVE_CPP_CONSTEVAL],[1])
AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
+ ], [AC_MSG_RESULT([no])], [AC_MSG_RESULT([assumed no (cross compiling)])])
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])