summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-07-30 13:40:52 +0200
committerMichael Stahl <Michael.Stahl@cib.de>2019-07-31 12:40:51 +0200
commit634844354ee6ed884128086a80c3ee32c889d8c9 (patch)
treeafdf2d9c4c5962ac7631d1f21dda03796307b666 /configure.ac
parente569b9d40eb02f53a3f13024af4ab1dc9ca7634a (diff)
sysui: fix rpm errors in freedesktop-menus (4.14.1)
RPM build errors: Explicit %attr() mode not applicable to symlink: /workdir/CustomTarget/sysui/rpm/libreofficedev/freedesktop/usr/bin/libreofficedev6.1 Installed (but unpackaged) file(s) found: /usr/local/lib/girepository-1.0/LOKDocView-0.1.typelib /usr/share/gir-1.0/LOKDocView-0.1.gir The LOKDocView problem turned out to be the result of the first incremental build after adding --with-package-format, and previously it was avoided with a if in configure; moving the commands out of create_tree.sh should be more obvious and reliable though. Change-Id: I69c1566e26eeaa1d8bf88a3650a78da6ddfb5a3b Reviewed-on: https://gerrit.libreoffice.org/76596 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f423018d574f..b3f5390428fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10431,10 +10431,7 @@ if test "x$enable_gtk3" = "xyes"; then
if test "x$ENABLE_GTK3" = "xTRUE"; then
AC_DEFINE(ENABLE_GTK3)
R="gtk3"
- dnl Avoid installed by unpackaged files for now.
- if test -z "$PKGFORMAT"; then
- GOBJECT_INTROSPECTION_CHECK(INTROSPECTION_REQUIRED_VERSION)
- fi
+ GOBJECT_INTROSPECTION_CHECK(INTROSPECTION_REQUIRED_VERSION)
else
AC_MSG_ERROR([gtk3 or dependent libraries of the correct versions, not found])
fi