summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2014-02-14 15:10:32 +0100
committerStephan Bergmann <sbergman@redhat.com>2014-02-14 15:10:32 +0100
commitbfd6428fff6e9cbd2e1bfde76a237bd438a8c9a6 (patch)
tree0a1c8ecda103252bb17f150fb62788332d406a08 /configure.ac
parent7273e371bec8042699d27f3ada83f1f50073ac15 (diff)
Hack for mysql_config under linux32
Change-Id: I3a6b4aae36df7e23c05da9fd27b0588a6228b92b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 39cd00956372..4f71d15b7a00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8056,6 +8056,14 @@ if test "$ENABLE_MARIADBC" = "TRUE"; then
MARIADB_CFLAGS=$(printf '%s' "$MARIADB_CFLAGS" | sed -e s/-fstack-protector-strong//)
fi
MARIADB_LIBS=`$MARIADBCONFIG --libs_r`
+ dnl At least mariadb-5.5.34-3.fc20.x86_64 plus
+ dnl mariadb-5.5.34-3.fc20.i686 reports 64-bit specific output even under
+ dnl linux32:
+ if test "$OS" = LINUX -a "$CPUNAME" = INTEL; then
+ MARIADB_CFLAGS=$(printf '%s' "$MARIADB_CFLAGS" | sed -e s/-m64//)
+ MARIADB_LIBS=$(printf '%s' "$MARIADB_LIBS" \
+ | sed -e 's|/lib64/|/lib/|')
+ fi
AC_MSG_RESULT([includes '$MARIADB_CFLAGS', libraries '$MARIADB_LIBS'])
AC_MSG_CHECKING([whether to bundle the MySQL/MariaDB client library])
if test "$enable_bundle_mariadb" = "yes"; then