summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2020-10-02 02:47:15 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2020-10-02 04:43:55 +0200
commit0227a8494463ef1c035ba3477ddf4c62c289edd0 (patch)
tree95098c1515e1e0aa8420b870906aebd71315b91b /configure.ac
parent77ba9a095b0b3f429e006571e16f8320ba0bb61e (diff)
gpgme, coinmp, firebird: disable on Windows Arm64
There is currently no gpgme package for Arm64, coinmp uses MSbuild, which probably just needs an additional ARM64 build target via VS. Firebird configure fails with cross-build errors, and I simply stopped early trying to fix them. I'm actually wondering, why LO doesn't use the VS solutions to build Firebird on Windows. Change-Id: I3acbe91e1df287afd557a07b48e3db46b31e6d95 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/103781 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e235dabcc8b1..da140708196b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -699,6 +699,12 @@ cygwin*|interix*)
DLLPOST=".dll"
LINKFLAGSNOUNDEFS=
+
+ if test "$host_cpu" = "aarch64"; then
+ enable_gpgmepp=no
+ enable_coinmp=no
+ enable_firebird_sdbc=no
+ fi
;;
darwin*|macos*) # macOS