summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2020-09-11 20:06:51 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2020-09-11 20:14:46 +0200
commit1ee5147d2088606492de65bd8084a44db537b5c9 (patch)
tree9e414b1fa52f1cfe01191e6eec40aa02169df3b6 /configure.ac
parent1bd3474c7c7945e1182dfbaca89be05ea98dd3e8 (diff)
Fix naming in configure.ac
Regression from commit 63972e79bbb9ea9654e755381641052632b0402c Change-Id: Icb8e4aa7c1c837640c61334f7a0983a771a43df6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6ae8f714e5fa..86772c2043c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4963,8 +4963,8 @@ if test "$cross_compiling" = "yes"; then
2>&1 | sed -e 's/^/ /'
test -f ./config_host.mk 2>/dev/null || exit
- # filter accepted build types
- BUILD_TARGETS_WHITELIST="
+ # filter permitted build targets
+ PERMITTED_BUILD_TARGETS="
AVMEDIA
BOOST
CLUCENE
@@ -4993,10 +4993,11 @@ if test "$cross_compiling" = "yes"; then
SCRIPTING
ZLIB
"
- # converts BUILD_TYPE and whitelist into non-whitespace, newlined lists, to use grep as a filter
- BUILD_TARGETS_WHITELIST=$(echo "$BUILD_TARGETS_WHITELIST" | sed -e '/^ *$/d' -e 's/ *//')
+ # converts BUILD_TYPE and PERMITTED_BUILD_TARGETS into non-whitespace,
+ # newlined lists, to use grep as a filter
+ PERMITTED_BUILD_TARGETS=$(echo "$PERMITTED_BUILD_TARGETS" | sed -e '/^ *$/d' -e 's/ *//')
BUILD_TARGETS="$(sed -ne '/^export BUILD_TYPE=/ { s/.*=// ; s/ /\n/gp }' config_host.mk)"
- BUILD_TARGETS="$(echo "$BUILD_TARGETS" | grep -F "$BUILD_TARGETS_WHITELIST" | tr '\n' ' ')"
+ BUILD_TARGETS="$(echo "$BUILD_TARGETS" | grep -F "$PERMITTED_BUILD_TARGETS" | tr '\n' ' ')"
sed -i -e "s/ BUILD_TYPE=.*$/ BUILD_TYPE=$BUILD_TARGETS/" config_host.mk
cp config_host.mk ../config_build.mk