summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.com>2020-09-07 11:07:09 +0200
committerMiklos Vajna <vmiklos@collabora.com>2020-09-07 17:01:48 +0200
commita4bcac651292961889bb708ecaad3b194758c58e (patch)
tree4128c9bb732db123effd4983e858f6a94b32477b /configure.ac
parent0cf956017477ad4f6aaae413eb434ab9b870725d (diff)
Android: re-enable pdfium
This was disabled by accident at some stage, the original commit b6f9eeb9b5c0e29ca655185dc299ebd4a2c092d7 (external: bundle pdfium, 2017-02-08) did have Android enabled back then. Change-Id: Ia875ba6c663d74e6c9061f4ffe814bc124431abe Reviewed-on: https://gerrit.libreoffice.org/c/core/+/102155 Tested-by: Jenkins Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 02d9f81bb551..85a722cb0410 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11151,7 +11151,7 @@ AC_SUBST([ENABLE_DCONF])
# pdf import?
AC_MSG_CHECKING([whether to build the PDF import feature])
ENABLE_PDFIMPORT=
-if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_pdfimport" = yes \); then
+if test $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_pdfimport" = yes \); then
AC_MSG_RESULT([yes])
ENABLE_PDFIMPORT=TRUE
AC_DEFINE(HAVE_FEATURE_PDFIMPORT)
@@ -11177,7 +11177,7 @@ dnl Check for poppler
dnl ===================================================================
ENABLE_POPPLER=
AC_MSG_CHECKING([whether to build Poppler])
-if test \( -z "$enable_poppler" -a "$ENABLE_PDFIMPORT" = "TRUE" \) -o "$enable_poppler" = yes; then
+if test \( -z "$enable_poppler" -a "$ENABLE_PDFIMPORT" = "TRUE" -a $_os != Android \) -o "$enable_poppler" = yes; then
AC_MSG_RESULT([yes])
ENABLE_POPPLER=TRUE
AC_DEFINE(HAVE_FEATURE_POPPLER)