summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamas Bunth <tamas.bunth@collabora.co.uk>2018-08-16 16:35:17 +0200
committerTamás Bunth <btomi96@gmail.com>2018-08-24 17:19:51 +0200
commit26b40fcfc67480e75bd9959b0c5cb9db10fdf6a1 (patch)
tree0d36eda88da5d9f1a28a5b915494d08c55456a02 /configure.ac
parent84c02b6d9f2fbe6658b58182f57d60e2bc797016 (diff)
Moving mysqlc into connectivity as a library
Additionally I erased the remains of the old mysql C++ connector. Also update the code where the clang plugins were unhappy after moving the mysqlc module. Remove mysql-cpp-connector external. Change-Id: I771cc7afacf5012fc349afb6b36828fb0fee5a66 Reviewed-on: https://gerrit.libreoffice.org/59200 Tested-by: Jenkins Reviewed-by: Tamás Bunth <btomi96@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 8 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 88dd8bfb3e1a..0bd0b862729e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1005,11 +1005,6 @@ AC_ARG_ENABLE(dynamic-loading,
[Disable any use of dynamic loading of code. Work in progress, use only if you are hacking on it.])
)
-libo_FUZZ_ARG_ENABLE(ext-mariadb-connector,
- AS_HELP_STRING([--enable-ext-mariadb-connector],
- [Enable the build of the MariaDB/MySQL Connector extension.])
-)
-
libo_FUZZ_ARG_ENABLE(report-builder,
AS_HELP_STRING([--disable-report-builder],
[Disable the Report Builder.])
@@ -1731,12 +1726,12 @@ AC_ARG_WITH(system-apache-commons,
AC_ARG_WITH(system-mariadb,
AS_HELP_STRING([--with-system-mariadb],
[Use MariaDB/MySQL libraries already on system, for building the MariaDB Connector/LibreOffice
- extension.]),,
+ .]),,
[with_system_mariadb="$with_system_libs"])
AC_ARG_ENABLE(bundle-mariadb,
AS_HELP_STRING([--enable-bundle-mariadb],
- [When using MariaDB/MySQL libraries already on system, bundle them with the MariaDB Connector/LibreOffice extension.])
+ [When using MariaDB/MySQL libraries already on system, bundle them with the MariaDB Connector/LibreOffice.])
)
AC_ARG_WITH(system-mysql-cppconn,
@@ -8320,18 +8315,12 @@ AC_SUBST(PYTHON_VERSION)
AC_SUBST(PYTHON_VERSION_MAJOR)
AC_SUBST(PYTHON_VERSION_MINOR)
-AC_MSG_CHECKING([whether to build the MariaDB/MySQL Connector extension])
-if test "x$enable_ext_mariadb_connector" = "xyes" -a "x$enable_extension_integration" != "xno"; then
- AC_MSG_RESULT([yes])
- ENABLE_MARIADBC=TRUE
- MARIADBC_MAJOR=1
- MARIADBC_MINOR=0
- MARIADBC_MICRO=2
- BUILD_TYPE="$BUILD_TYPE MARIADBC"
-else
- AC_MSG_RESULT([no])
- ENABLE_MARIADBC=
-fi
+ENABLE_MARIADBC=TRUE
+MARIADBC_MAJOR=1
+MARIADBC_MINOR=0
+MARIADBC_MICRO=2
+BUILD_TYPE="$BUILD_TYPE MARIADBC"
+
AC_SUBST(ENABLE_MARIADBC)
AC_SUBST(MARIADBC_MAJOR)
AC_SUBST(MARIADBC_MINOR)
@@ -12550,9 +12539,6 @@ if test "$enable_mpl_subset" = "yes"; then
if test "$WITH_WEBDAV" = "neon"; then
AC_MSG_ERROR([need --with-webdav=serf or --without-webdav - webdav support.])
fi
- if test "x$enable_ext_mariadb_connector" = "xyes"; then
- AC_MSG_ERROR([need to --disable-ext-mariadb-connector - mariadb/mysql support.])
- fi
if test -n "$ENABLE_PDFIMPORT"; then
if test "x$SYSTEM_POPPLER" = "x"; then
AC_MSG_ERROR([need to disable PDF import via poppler or use system library])