summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-04-17 17:30:39 +0200
committerStephan Bergmann <sbergman@redhat.com>2020-05-27 16:46:16 +0200
commit54b8a23f96944df17c6a05341b25b315c62ad2da (patch)
treea3744a06a6525ec0f0f223b02e39bdfb99f28860 /configure.ac
parentacdde3c643fde015214c546b1567727272ea799e (diff)
Remove obsolete configure checks after libreoffice-7-0 branch off
By now, any outdated builders where this would fail should have been identified and taken care of. Change-Id: If0af9fc390e7c132e08d0ec673c9073d92a028f0 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92458 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 354fd902b953..929b06ed8af7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6440,20 +6440,6 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
-
- dnl Available in GCC 4.9 and at least since Clang 3.4; this check can eventually be removed
- dnl completely (e.g., after libreoffice-6-5 branch off):
- AC_MSG_CHECKING([that $CXX_BASE supports __attribute__((warn_unused))])
- AC_LANG_PUSH([C++])
- save_CXXFLAGS=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS -Werror"
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- struct __attribute__((warn_unused)) dummy {};
- ])], [
- AC_MSG_RESULT([yes])
- ], [AC_MSG_ERROR([no])])
- CXXFLAGS=$save_CXXFLAGS
-AC_LANG_POP([C++])
fi
AC_SUBST(HAVE_GCC_AVX)
@@ -6680,30 +6666,6 @@ if test "$GCC" = yes; then
fi
AC_SUBST([HAVE_GCC_FNO_SIZED_DEALLOCATION])
-dnl This check can eventually be removed completely (e.g., after libreoffice-7-0 branch off):
-AC_MSG_CHECKING([that $CXX_BASE supports guaranteed copy elision])
-AC_LANG_PUSH([C++])
-save_CXXFLAGS=$CXXFLAGS
-CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
-AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- // At least VS 2017 15.8.1 defines __cpp_guaranteed_copy_elision as 201606L without actually
- // supporting it:
- #if !defined __cpp_guaranteed_copy_elision || (defined _MSC_VER && !defined __clang__)
- struct S {
- private:
- S(S const &);
- public:
- S();
- ~S();
- };
- S copy();
- void f() { S c(copy()); }
- #endif
- ])], [AC_MSG_RESULT([yes])
- ], [AC_MSG_ERROR([no])])
-CXXFLAGS=$save_CXXFLAGS
-AC_LANG_POP([C++])
-
AC_MSG_CHECKING([whether $CXX_BASE supports C++2a constinit sorted vectors])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS