summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2016-06-29 15:32:00 +0200
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2016-06-29 22:46:20 +0000
commit76c2125ee3eeb64a95501c26c2fa660cd0f8818c (patch)
tree9fd218448807ab93e6bf7bd95357b37d0a92e1e9 /configure.ac
parent11f69994b0231a760231b712d9faf6806334232f (diff)
Add MS binary format validator support for wine
Run bffvalidator also from Linux, reportedly works from wine 1.9 upwards. Wraps stuff in a shell for path name conversion. Change-Id: I3093b10bbbf89aaff97f63485b8ccadb417b3561 Reviewed-on: https://gerrit.libreoffice.org/26784 Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d99b4b4266a3..39bc17f059fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2796,7 +2796,14 @@ if test "$with_bffvalidator" != "no"; then
else
AC_MSG_ERROR([bffvalidator not found, but required by --with-bffvalidator])
fi
- elif test -n "$BFFVALIDATOR" -a -e "$BFFVALIDATOR"; then
+ elif test -n "$BFFVALIDATOR"; then
+ # We are not in CygWin but need to run Windows binary with wine
+ AC_PATH_PROGS(WINE, wine)
+
+ # so swap in a shell wrapper that converts paths transparently
+ BFFVALIDATOR_EXE="$BFFVALIDATOR"
+ BFFVALIDATOR="$SRC_ROOT/bin/bffvalidator.sh"
+ AC_SUBST(BFFVALIDATOR_EXE)
AC_MSG_RESULT($BFFVALIDATOR)
else
AC_MSG_ERROR([bffvalidator not found, but required by --with-bffvalidator])
@@ -4657,6 +4664,7 @@ if test "$cross_compiling" = "yes"; then
config_host_lang.mk.in \
Makefile.in \
lo.xcent.in \
+ bin/bffvalidator.sh.in \
instsetoo_native/util/openoffice.lst.in \
config_host/*.in \
sysui/desktop/macosx/Info.plist.in \
@@ -12991,6 +12999,7 @@ AC_CONFIG_FILES([config_host.mk
config_host_lang.mk
Makefile
lo.xcent
+ bin/bffvalidator.sh
instsetoo_native/util/openoffice.lst
sysui/desktop/macosx/Info.plist
ios/lo.xcconfig])