summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVasily Melenchuk <vasily.melenchuk@cib.de>2016-06-23 14:20:58 +0300
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2016-07-21 01:47:02 +0000
commita59b6be0850a68a1bb5d7099a004a86c0fcb6e40 (patch)
tree8e3bb841728bb678540488bd6f633e01790c8fb1 /configure.ac
parent0ccb3ccc4c7bafeb2fbbd689c90f710bc65d37e0 (diff)
odfvalidator support in export tests without external repositories
Fetching external tarball for Apache ODF Toolkit, configuration of wrapper script for odf validator execution Change-Id: I8b3824a91ebc6ddc196416e197b6c688964a13a9 Reviewed-on: https://gerrit.libreoffice.org/26596 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 23 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index a91de785034a..d93de7908d86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2732,22 +2732,29 @@ if test "$with_export_validation" = yes; then
AC_MSG_RESULT([yes])
AC_DEFINE(HAVE_EXPORT_VALIDATION)
- if test "$build_os" = "cygwin"; then
- # In case of CygWin it will be executed from Windows,
- # so we need to run bash and absolute path to validator
- # so instead of "odfvalidator" it will be
- # something like "bash.exe C:\cygwin\opt\lo\bin\odfvalidator"
- AC_PATH_PROGS(ODFVALIDATOR, odfvalidator)
- if test -z "$ODFVALIDATOR"; then
- AC_MSG_ERROR([odfvalidator not found, but required by --with-export-validation])
+ AC_PATH_PROGS(ODFVALIDATOR, odfvalidator)
+ if test -z "$ODFVALIDATOR"; then
+ # remember to download the ODF toolkit with validator later
+ AC_MSG_NOTICE([no odfvalidator found, will download it])
+ BUILD_TYPE="$BUILD_TYPE ODFVALIDATOR"
+ ODFVALIDATOR="bin/odfvalidator.sh"
+
+ # and fetch name of odfvalidator jar name from download.lst
+ ODFVALIDATOR_JAR=`sed -ne "s/export *ODFVALIDATOR_JAR *:= *\(.*\) */\1/p" download.lst`
+ AC_SUBST(ODFVALIDATOR_JAR)
+
+ if test -z "$ODFVALIDATOR_JAR"; then
+ AC_MSG_ERROR([odfvalidator jar location is not determined (--with-export-validation)])
fi
- ODFVALIDATOR="bash.exe `cygpath -m "$ODFVALIDATOR"`"
- else
- AC_CHECK_PROGS(ODFVALIDATOR, odfvalidator)
- if test -z "$ODFVALIDATOR"; then
- AC_MSG_ERROR([odfvalidator not found, but required by --with-export-validation])
+
+ if test "$build_os" = "cygwin"; then
+ # In case of CygWin it will be executed from Windows,
+ # so we need to run bash and absolute path to validator
+ # so instead of "odfvalidator" it will be
+ # something like "bash.exe C:\cygwin\opt\lo\bin\odfvalidator"
+ ODFVALIDATOR="bash.exe `cygpath -m "$ODFVALIDATOR"`"
fi
- fi
+ fi
AC_SUBST(ODFVALIDATOR)
if test "$build_os" = "cygwin"; then
@@ -4663,6 +4670,7 @@ if test "$cross_compiling" = "yes"; then
Makefile.in \
lo.xcent.in \
bin/bffvalidator.sh.in \
+ bin/odfvalidator.sh.in \
instsetoo_native/util/openoffice.lst.in \
config_host/*.in \
sysui/desktop/macosx/Info.plist.in \
@@ -12998,6 +13006,7 @@ AC_CONFIG_FILES([config_host.mk
Makefile
lo.xcent
bin/bffvalidator.sh
+ bin/odfvalidator.sh
instsetoo_native/util/openoffice.lst
sysui/desktop/macosx/Info.plist
ios/lo.xcconfig])