summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2020-07-07 10:36:13 +0200
committerMichael Stahl <michael.stahl@cib.de>2020-07-07 18:39:49 +0200
commitd68fc8d10da9047534f0e7a2d5ebc59f13745442 (patch)
tree5e60176cdbaa33c95e1a3db8227b16ec938981e9 /configure.ac
parent2ad32b39af2e00ef253a2ef99e033feef416808f (diff)
configure: try to fail early if qt5 header QtCore/qconfig-32.h missing
Unfortunately configure passes successfully if qt5-qtbase-devel-*.x86_64 is installed but the host cpu is i686. Change-Id: Ib155d6f91676c12a480eed2f0d4d38c05377e909 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/98240 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd1e6a52c615..f0492335a9d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11929,6 +11929,9 @@ then
if test "x$qt5_incdir" = "xno"; then
AC_MSG_ERROR([Qt5 headers not found. Please specify the root of your Qt5 installation by exporting QT5DIR before running "configure".])
fi
+ # check for scenario: qt5-qtbase-devel-*.86_64 installed but host is i686
+ AC_CHECK_HEADER(QtCore/qconfig.h, [],
+ [AC_MSG_ERROR(qconfig.h header not found.)], [])
AC_MSG_CHECKING([for Qt5 libraries])
qt5_libdir="no"