summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2022-07-21 15:57:53 +0200
committerLuboš Luňák <l.lunak@collabora.com>2022-07-22 19:16:16 +0200
commit4fbcededefa07a97aa9ca55986241a0dd0146806 (patch)
tree0c72fa9f5e8bb8dc3e40ca9b00fa8104a341a69d /configure.ac
parent5a8a1c4a86938b65c5ea7807f60e721946d7d8de (diff)
require wsl-lo-helper to be preinstalled, like 'make'
It is needed to even find MSVC, so configure cannot easily build it. Change-Id: Ie4e950cf01b9d8778cdc3e9a53718954b0c3c166 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137344 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2bf56df211d9..eca0ab405c85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,7 +119,7 @@ PathFormat()
formatted_path=$(wslpath -w "$formatted_path")
;;
esac
- formatted_path=$($BUILDDIR/solenv/wsl/wsl-lo-helper.exe --8.3 "$formatted_path")
+ formatted_path=$($WSL_LO_HELPER --8.3 "$formatted_path")
elif test "$GNUMAKE_WIN_NATIVE" = "TRUE" ; then
formatted_path=`cygpath -sm "$formatted_path"`
else
@@ -355,7 +355,7 @@ if test -z "$host" -a -z "$build" -a "$(uname -r | grep -i Microsoft 2>/dev/null
;;
esac
if test -n "$opt_d" -o -n "$opt_s"; then
- input=$($BUILDDIR/solenv/wsl/wsl-lo-helper.exe --8.3 "$input")
+ input=$($WSL_LO_HELPER --8.3 "$input")
fi
if test -n "$opt_m"; then
input="${input//\\//}"
@@ -399,6 +399,17 @@ if test -z "$host" -a -z "$build" -a "$(uname -r | grep -i Microsoft 2>/dev/null
exit 0
fi
+
+ if test -z "$WSL_LO_HELPER"; then
+ if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/wsl-lo-helper" ; then
+ WSL_LO_HELPER="$LODE_HOME/opt/bin/wsl-lo-helper"
+ elif test -x "/opt/lo/bin/wsl-lo-helper"; then
+ WSL_LO_HELPER="/opt/lo/bin/wsl-lo-helper"
+ fi
+ fi
+ if test -z "$WSL_LO_HELPER"; then
+ AC_MSG_ERROR([wsl-lo-helper not found. See solenv/wsl/README.])
+ fi
fi
AC_CANONICAL_HOST
@@ -3811,7 +3822,7 @@ reg_get_value()
unset regvalue
if test "$build_os" = "wsl"; then
- regvalue=$($BUILDDIR/solenv/wsl/wsl-lo-helper.exe --read-registry $1 "$2" 2>/dev/null)
+ regvalue=$($WSL_LO_HELPER --read-registry $1 "$2" 2>/dev/null)
return
fi