summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2022-07-21 14:55:28 +0200
committerLuboš Luňák <l.lunak@collabora.com>2022-07-22 19:15:53 +0200
commit5a8a1c4a86938b65c5ea7807f60e721946d7d8de (patch)
tree8a021f59ddf16038570a9426166d37b72e445484 /configure.ac
parent5b04eed4d22c9e3caa76e195582b15862e9261b6 (diff)
use uname for detecting WSL
There's no wslsys in my WSL setup. I also don't see why WSL should be at least version 2, they both should(?) work and it is recommended to use version 1 with NTFS (and version 2 also doesn't work e.g. inside VirtualBox). Change-Id: I5b9440f65624f49e331d84235046e4dd2e31af4e Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137343 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6b7070c78d87..2bf56df211d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,9 +288,9 @@ dnl checks build and host OSes
dnl do this before argument processing to allow for platform dependent defaults
dnl ===================================================================
-# Check for WSL (version 2, at least). But if --host is explicitly specified (to really do build for
+# Check for WSL. But if --host is explicitly specified (to really do build for
# Linux on WSL) trust that.
-if test -z "$host" -a -z "$build" -a "`wslsys -v 2>/dev/null`" != ""; then
+if test -z "$host" -a -z "$build" -a "$(uname -r | grep -i Microsoft 2>/dev/null)" != ""; then
ac_cv_host="x86_64-pc-wsl"
ac_cv_host_cpu="x86_64"
ac_cv_host_os="wsl"