summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-08-30 14:29:14 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2013-08-30 19:59:54 +0000
commit5b7dff553cf51ecc3d21a2231861390d16ccf0eb (patch)
treebe8a23e9277d0d8d6e566306754f4a0717201eec /configure.ac
parentaa05e128de6a8dd0382d0c324676c728dc347ac0 (diff)
ENABLE_MACOSX_SANDBOX Harmonize ENABLE_* variable to TRUE/<nothing>
Change-Id: Ice05796a9887c4ff311b78fcddd9820e0f06e7f1 Reviewed-on: https://gerrit.libreoffice.org/5708 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d82828866e53..f613f9f64203 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2781,7 +2781,7 @@ if test $_os = Darwin; then
elif test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([OS X sandboxing (actually App Store rules) disallows use of Java])
elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
- ENABLE_MACOSX_SANDBOX=YES
+ ENABLE_MACOSX_SANDBOX=TRUE
AC_DEFINE(HAVE_FEATURE_MACOSX_SANDBOX)
AC_MSG_RESULT([yes])
else
@@ -2853,7 +2853,7 @@ fi
AC_MSG_CHECKING([whether to treat the installation as read-only])
-if test \( -z "$enable_readonly_installset" -a "$ENABLE_MACOSX_SANDBOX" = YES \) -o \
+if test \( -z "$enable_readonly_installset" -a "$ENABLE_MACOSX_SANDBOX" = TRUE \) -o \
"$enable_extensions" != yes; then
enable_readonly_installset=yes
fi