summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2022-07-21 15:59:50 +0200
committerLuboš Luňák <l.lunak@collabora.com>2022-07-22 19:16:29 +0200
commit981ba02267af461792c3ff30b8fecc5cd73497a3 (patch)
treee06107aa4f2cd7dc07820216e41750d456065a4e /configure.ac
parent4fbcededefa07a97aa9ca55986241a0dd0146806 (diff)
add fallback for $PROGRAMFILESX86
It's not set in my WSL, but since it's going to be c:\program files (x86) in the vast majority of cases, just hardcode a fallback. Change-Id: I3bf41d6bae0e5bb36c53f0a4cf913a980a058fcf Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137345 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eca0ab405c85..67493ea442e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4052,6 +4052,9 @@ find_msvc()
vs_versions_to_check "$1"
if test "$build_os" = wsl; then
vswhere="$PROGRAMFILESX86"
+ if test -z "$vswhere"; then
+ vswhere="c:\\Program Files (x86)"
+ fi
else
vswhere="$(perl -e 'print $ENV{"ProgramFiles(x86)"}')"
fi