summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-09-14 17:26:17 +0200
committerStephan Bergmann <sbergman@redhat.com>2022-06-10 17:15:49 +0200
commita8485d558fab53291e2530fd9a1be581c1628deb (patch)
treedff1f2885f954b9da2d3d2dbb9adc20b5b69c69c /configure.ac
parent611fe67394820e589e86f543c614632fc273eb5e (diff)
[API CHANGE] Remove deprecated idlc and regmerge from the SDK
* Client code must replace uses of idlc and regmerge with uses of unoidl-write, see the changes to odk/examples/ and ure/source/uretext/ in 40f2aee6584eafcf4cd1d95fcf1f775e5435440d "Provide unoidl-write also for the SDK" for examples. * The new types.rdb format is not compatible with LibreOffice < 4.1. Clients generating extensions containing such files are advised to use appropriate LibreOffice-minimal-version elements. * For compatibility with old extensions, reading the legacy types.rdb format is still supported. * The SDK no longer ships an idl/ sub-directory containing the udkap and offapi .idl files (as, unlike idlc, unoidl-write does not need them). odk/config/cfgWin.js had to be adapted to look (somewhat arbitrarily) for an examples/ sub-directory instead of idl/ when checking for "an sdk folder". gb_UnoApi_package_idlfiles became unused and has been removed. * The idlc and regmerge executables have been removed. Module idlc has been removed except for idlc/test/parser/, which is also used by CustomTarget_unoidl/unoidl-write_test, and which may eventually be moved into module unoidl. Module external/ucpp and the corresponding configure options have also been removed. Change-Id: I42a0231699b863b5ebe2bee63bc32c8f79278cc1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/122363 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 0 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index 2ff842f2b595..11e697c733f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2214,11 +2214,6 @@ AC_ARG_WITH(system-libxml,
[Use libxml/libxslt already on system.]),,
[with_system_libxml=auto])
-AC_ARG_WITH(system-ucpp,
- AS_HELP_STRING([--with-system-ucpp],
- [Use ucpp already on system.]),,
- [])
-
AC_ARG_WITH(system-openldap,
AS_HELP_STRING([--with-system-openldap],
[Use the OpenLDAP LDAP SDK already on system.]),,
@@ -2738,11 +2733,6 @@ AC_ARG_WITH(os-version,
[For FreeBSD users, use this option to override the detected OSVERSION.]),
,)
-AC_ARG_WITH(idlc-cpp,
- AS_HELP_STRING([--with-idlc-cpp=<cpp/ucpp>],
- [Specify the C Preprocessor to use for idlc. Default is ucpp.]),
-,)
-
AC_ARG_WITH(parallelism,
AS_HELP_STRING([--with-parallelism],
[Number of jobs to run simultaneously during build. Parallel builds can
@@ -9058,40 +9048,6 @@ else
fi
dnl ===================================================================
-dnl Check for C preprocessor to use
-dnl ===================================================================
-AC_MSG_CHECKING([which C preprocessor to use in idlc])
-SYSTEM_UCPP_IS_GCC=
-if test -n "$with_idlc_cpp"; then
- AC_MSG_RESULT([$with_idlc_cpp])
- AC_PATH_PROG(SYSTEM_UCPP, $with_idlc_cpp)
- AC_MSG_CHECKING([if $with_idlc_cpp is GCC CPP])
- # ucpp will accept -v (to output version), warn about the others as unknown
- # and return 1 (due to -v)
- # gcc will accept -v (as verbose), --version (to output version) and -nostdinc
- # and return 0 (due to --version ) if all options are supported
- $SYSTEM_UCPP -v --version -nostdinc >/dev/null 2>/dev/null
- if test $? -eq 0; then
- SYSTEM_UCPP_IS_GCC=TRUE
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-else
- AC_MSG_RESULT([ucpp])
- AC_MSG_CHECKING([which ucpp to use])
- if test -n "$with_system_ucpp" -a "$with_system_ucpp" != "no"; then
- AC_MSG_RESULT([external])
- AC_PATH_PROG(SYSTEM_UCPP, ucpp)
- else
- AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE UCPP"
- fi
-fi
-AC_SUBST(SYSTEM_UCPP)
-AC_SUBST(SYSTEM_UCPP_IS_GCC)
-
-dnl ===================================================================
dnl Check for epm (not needed for Windows)
dnl ===================================================================
AC_MSG_CHECKING([whether to enable EPM for packing])