summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-09-05 13:15:07 +0300
committerTor Lillqvist <tml@collabora.com>2013-09-05 13:34:25 +0300
commitac4e19f9085dbd0103c7336a5318aa1e55b3e3e0 (patch)
treebb42afc7d1d73e42e38e344dc3ad221479f4e295 /configure.ac
parent4c30c48684cd09a057906f30d7a3f8927ecabb52 (diff)
fdo#68552: Don't (attempt to) do run-time expansion of build-time parameters
The $(share_subdir_name) things in the filter fragment .xcu files didn't actually work it seems. But anyway, it's a bit silly to do expansion at run-time of $(foo) things known at build-time anyway. Thanks to sberg for pointing this out. So just use the normal configury .in mechanism for these. Simpler. Change-Id: I14b3e5cc5169b34df8a1d7ff07cc28452c67bcc8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2f20dd1de6a8..c1425a77b375 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12519,7 +12519,25 @@ if test -f config_host.mk; then
config_md5=`$MD5SUM config_host.mk | sed "s/ .*//"`
fi
-AC_CONFIG_FILES([config_host.mk Makefile lo.xcent instsetoo_native/util/openoffice.lst])
+AC_CONFIG_FILES([config_host.mk
+ Makefile
+ lo.xcent
+ filter/source/config/fragments/filters/DocBook_File.xcu
+ filter/source/config/fragments/filters/MS_Excel_2003_XML.xcu
+ filter/source/config/fragments/filters/MS_Word_2003_XML.xcu
+ filter/source/config/fragments/filters/UOF_presentation.xcu
+ filter/source/config/fragments/filters/UOF_spreadsheet.xcu
+ filter/source/config/fragments/filters/UOF_text.xcu
+ filter/source/config/fragments/filters/XHTML_Calc_File.xcu
+ filter/source/config/fragments/filters/XHTML_Draw_File.xcu
+ filter/source/config/fragments/filters/XHTML_Impress_File.xcu
+ filter/source/config/fragments/filters/XHTML_Writer_File.xcu
+ officecfg/registry/data/org/openoffice/Office/Paths.xcu
+ officecfg/registry/data/org/openoffice/Office/WebWizard.xcu
+ officecfg/registry/schema/org/openoffice/Office/Common.xcs
+ wizards/source/configshare/dialog.xlc
+ wizards/source/configshare/script.xlc
+ instsetoo_native/util/openoffice.lst])
AC_CONFIG_HEADERS([config_host/config_buildid.h])
AC_CONFIG_HEADERS([config_host/config_clang.h])
AC_CONFIG_HEADERS([config_host/config_features.h])