summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2022-06-29 13:35:01 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2022-06-29 17:06:35 +0200
commitb43f0b0295953c8d5d16c5b9eccaddb5ec214bab (patch)
treeb1144afc20af14dacb88eed3961a82ca76392c30 /configure.ac
parentd121e7cdd408fa5afb73b16466df42baa52b6a1a (diff)
allow to specify a macOS provisioning profile
having one is one of the prerequisites of using TestFlight Change-Id: I9e20eb99905071fade4179dfbe2da5b7e5dd1c24 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/136618 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 919c3a8533e0..08395ac66677 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1899,6 +1899,11 @@ AC_ARG_WITH(macosx-bundle-identifier,
org.libreoffice.script ("script", huh?).]),
,with_macosx_bundle_identifier=org.libreoffice.script)
+AC_ARG_WITH(macosx-provisioning-profile,
+ AS_HELP_STRING([--with-macosx-provisioning-profile=/path/to/mac.provisionprofile],
+ [Specify the path to a provisioning profile to use]),
+,)
+
AC_ARG_WITH(product-name,
AS_HELP_STRING([--with-product-name='My Own Office Suite'],
[Define the product name. Default is AC_PACKAGE_NAME.]),
@@ -3615,6 +3620,18 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what macOS app bundle identifier to use])
MACOSX_BUNDLE_IDENTIFIER=$with_macosx_bundle_identifier
AC_MSG_RESULT([$MACOSX_BUNDLE_IDENTIFIER])
+
+ if test -n "$with_macosx_provisioning_profile" ; then
+ if test ! -f "$with_macosx_provisioning_profile"; then
+ AC_MSG_ERROR([provisioning profile not found at $with_macosx_provisioning_profile])
+ else
+ MACOSX_PROVISIONING_PROFILE=$with_macosx_provisioning_profile
+ MACOSX_PROVISIONING_INFO=$([security cms -D -i "$MACOSX_PROVISIONING_PROFILE" | \
+ xmllint --xpath "//key[.='com.apple.application-identifier' or .='com.apple.developer.team-identifier'] \
+ | //key[.='com.apple.application-identifier' or .='com.apple.developer.team-identifier']/following-sibling::string[1]" - | \
+ sed -e 's#><#>\n\t<#g' -e 's#^#\t#'])
+ fi
+ fi
fi
AC_SUBST(MACOSX_SDK_PATH)
AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
@@ -3625,6 +3642,8 @@ AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(MACOSX_PACKAGE_SIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_SUBST(MACOSX_PROVISIONING_INFO)
+AC_SUBST(MACOSX_PROVISIONING_PROFILE)
dnl ===================================================================
dnl Check iOS SDK and compiler