summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2022-05-08 14:52:10 +0200
committerLuboš Luňák <l.lunak@collabora.com>2022-05-09 09:13:41 +0200
commitc0f9157cf64242adbc4a9eb7cfac66fffa97e5a2 (patch)
tree38e65ba4d6ea8ba7dfa7ea4c60b0ae4b35570ce5 /configure.ac
parentcdf8e971d5d46df4bcab35a99c4254df9459213f (diff)
remove HAVE_LIBCPP_DEBUG (libc++ debug mode)
It's currently too broken (https://reviews.llvm.org/D125184), but they're working on fixing it, so hopefully somewhen later. Change-Id: I3ca243a57d41bd9d8c4cdbdc4a6a3b5fdc49e4c6 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/134023 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index ff4aa9cd1c8b..80058aaafb4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7419,26 +7419,6 @@ AC_LANG_POP([C++])
AC_SUBST([HAVE_LIBSTDCPP])
AC_SUBST([HAVE_LIBCPP])
-HAVE_LIBCPP_DEBUG=
-if test -n "$HAVE_LIBCPP" -a -n "$ENABLE_DBGUTIL"; then
- # libc++ supports debug mode only if built for it, Mac libc++ isn't,
- # and there would be undefined references to debug functions
- AC_MSG_CHECKING([if libc++ is built with debug mode])
- AC_LANG_PUSH([C++])
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#define _LIBCPP_DEBUG 1
-#include <vector>
-int foo(const std::vector<int>& v) { return *v.begin(); }
-]])],
- [AC_MSG_RESULT(yes)
- HAVE_LIBCPP_DEBUG=1
- ],
- [AC_MSG_RESULT(no)]
- )
- AC_LANG_POP([C++])
-fi
-AC_SUBST([HAVE_LIBCPP_DEBUG])
-
dnl ===================================================================
dnl Check for gperf
dnl ===================================================================