summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@rene-engelhard.de>2022-07-27 08:26:12 +0200
committerRené Engelhard <rene@debian.org>2022-07-27 11:52:23 +0200
commitc559dbd86474e4b0e5c2d0711508ab7f5efed6b5 (patch)
tree4ef84369cd3a35ccf99d2e916df25280ced0c315 /configure.ac
parent93f28ca499c6d15415f359a9e868a72bbcdc9b4b (diff)
rename GODSON/GODSON64 to MIPS/MIPS64
as that what it actually is and the compiler defines are already -DMIPS/-DMIPS64 anyway (as are the PLATFORMID and the bridges' name mips/mips64) Change-Id: I274e7a3b0e140375a8e697c1790cbdb972251d29 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137489 Tested-by: René Engelhard <rene@debian.org> Reviewed-by: Caolán McNamara <caolanm@redhat.com> Reviewed-by: René Engelhard <rene@debian.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 33dc0fb96316..52d21a3f88e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5190,25 +5190,25 @@ linux-gnu*|linux-musl*)
PLATFORMID=linux_ia64
;;
mips)
- CPUNAME=GODSON
+ CPUNAME=MIPS
RTL_ARCH=MIPS_EB
EPM_FLAGS="-a mips"
PLATFORMID=linux_mips_eb
;;
mips64)
- CPUNAME=GODSON64
+ CPUNAME=MIPS64
RTL_ARCH=MIPS64_EB
EPM_FLAGS="-a mips64"
PLATFORMID=linux_mips64_eb
;;
mips64el)
- CPUNAME=GODSON64
+ CPUNAME=MIPS64
RTL_ARCH=MIPS64_EL
EPM_FLAGS="-a mips64el"
PLATFORMID=linux_mips64_el
;;
mipsel)
- CPUNAME=GODSON
+ CPUNAME=MIPS
RTL_ARCH=MIPS_EL
EPM_FLAGS="-a mipsel"
PLATFORMID=linux_mips_el
@@ -8608,7 +8608,7 @@ if test "$ENABLE_JAVA" != ""; then
JAVAINTERPRETER=`win_short_path_for_make "$JAVAINTERPRETER"`
elif test "$cross_compiling" != "yes"; then
case $CPUNAME in
- AARCH64|AXP|X86_64|HPPA|IA64|POWERPC64|S390X|SPARC64|GODSON64)
+ AARCH64|AXP|X86_64|HPPA|IA64|POWERPC64|S390X|SPARC64|MIPS64)
if test -f "$JAVAINTERPRETER" -a "`$JAVAINTERPRETER -version 2>&1 | $GREP -i 64-bit`" = "" >/dev/null; then
AC_MSG_WARN([You are building 64-bit binaries but the JDK $JAVAINTERPRETER is 32-bit])
AC_MSG_ERROR([You should pass the --with-jdk-home option pointing to a 64-bit JDK])