summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwjh-la <wujiahuan@loongson.cn>2022-07-27 09:14:16 +0800
committerStephan Bergmann <sbergman@redhat.com>2022-08-11 10:53:00 +0200
commitd3625d968901eb93a9680db8d1165f70de3fd64e (patch)
treee58d5026cc1185a20de7f21c7060cba5594baaf7 /configure.ac
parent0b92cf674cd44bdd2c2cdf8a5d597d4407e34002 (diff)
Add loongarch64 support.
Loongarch is a new RISC ISA , which includes a 32-bit version and a 64-bit version, Here are some documents about Loongarch: https://github.com/loongson/LoongArch-Documentation. The loongarch64 bridges implementation refers to mips64 bridges, and the code related to abi and asm has been modified Change-Id: I1d9cd3aadf63046c8cdecc9a64842567bfa1cecc Reviewed-on: https://gerrit.libreoffice.org/c/core/+/137486 Tested-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 851c2afe9b94..c639bda264fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5263,6 +5263,11 @@ linux-gnu*|linux-musl*)
RTL_ARCH=X86_64
PLATFORMID=linux_x86_64
;;
+ loongarch64)
+ CPUNAME=LOONGARCH64
+ RTL_ARCH=LOONGARCH64
+ PLATFORMID=linux_loongarch64
+ ;;
*)
AC_MSG_ERROR([Unsupported host_cpu $host_cpu for host_os $host_os])
;;
@@ -12879,7 +12884,7 @@ AC_SUBST(RHINO_JAR)
# platforms there.
supports_multilib=
case "$host_cpu" in
-x86_64 | powerpc64 | powerpc64le | s390x | aarch64 | mips64 | mips64el)
+x86_64 | powerpc64 | powerpc64le | s390x | aarch64 | mips64 | mips64el | loongarch64)
if test "$SAL_TYPES_SIZEOFLONG" = "8"; then
supports_multilib="yes"
fi