summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-04-17 14:42:20 +0200
committerStephan Bergmann <sbergman@redhat.com>2020-04-17 17:23:29 +0200
commit4d1bd3cba9b4c971c05974a2805b018ec8ba18e2 (patch)
treeca2fe545df09fd0dc56fe44db3d50ef61c427436 /configure.ac
parent396b5ce076145ccda46cbfdac82faaad899a4e9d (diff)
HAVE_CPP_GUARANTEED_COPY_ELISION should always be true now
...since 24973523ba59087185d434396fd614e73d72107f "Bump Windows build baseline to Visual Studio 2019 16.4", where that version of the compiler appears to no longer have the issue that at least VS 2017 15.8.1 had. And according to <view-source:https://en.cppreference.com/w/cpp/compiler_support>, the other compilers support it since GCC 7 and Clang 4, so we should be OK there. But for safety, leave the configure.ac check in for some longer. Change-Id: I07bfaa554d897613c0887ab70e8df93f6e000410 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92422 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1eb9a1af7898..42945571edf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6678,7 +6678,8 @@ if test "$GCC" = yes; then
fi
AC_SUBST([HAVE_GCC_FNO_SIZED_DEALLOCATION])
-AC_MSG_CHECKING([whether $CXX_BASE supports guaranteed copy elision])
+dnl This check can eventually be removed completely (e.g., after libreoffice-7-0 branch off):
+AC_MSG_CHECKING([that $CXX_BASE supports guaranteed copy elision])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
@@ -6696,10 +6697,8 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
S copy();
void f() { S c(copy()); }
#endif
- ])], [
- AC_DEFINE([HAVE_CPP_GUARANTEED_COPY_ELISION],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
+ ])], [AC_MSG_RESULT([yes])
+ ], [AC_MSG_ERROR([no])])
CXXFLAGS=$save_CXXFLAGS
AC_LANG_POP([C++])