summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2020-04-20 16:28:23 +0200
committerLuboš Luňák <l.lunak@collabora.com>2020-04-20 17:49:40 +0200
commit4e61f3844982965dad4e206a8bf4dfec4174c805 (patch)
tree19829b705377c069e48d046647585770e525ac4c /configure.ac
parent59d0a42639b5e569890ae00a2deef620c4e5c258 (diff)
fix --enable-64-bit Windows build with Clang for Skia
Change-Id: Ia55e0b6ab6b970cbafe2c8283b255eae0ad66567 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/92577 Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com> Reviewed-by: Luboš Luňák <l.lunak@collabora.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 376bdf4816da..ada79b6dfd45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11130,9 +11130,11 @@ if test "$ENABLE_SKIA" = TRUE -a "$COM_IS_CLANG" != TRUE; then
AC_MSG_CHECKING([for clang-cl])
if test -x "$VC_PRODUCT_DIR/Tools/Llvm/bin/clang-cl.exe"; then
CLANG_C=`win_short_path_for_make "$VC_PRODUCT_DIR/Tools/Llvm/bin/clang-cl.exe"`
+ dnl match our MSVC default, also explicitly set -m32/-m64
if test "$BITNESS_OVERRIDE" = ""; then
- dnl match our MSVC default
- CLANG_C="$CLANG_C -arch:SSE"
+ CLANG_C="$CLANG_C -m32 -arch:SSE"
+ else
+ CLANG_C="$CLANG_C -m64"
fi
CLANG_CXX="$CLANG_C"
AC_MSG_RESULT([$CLANG_C])