summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2022-05-11 10:09:12 +0200
committerLuboš Luňák <l.lunak@collabora.com>2022-05-11 11:58:58 +0200
commit35dec195a1f0a7a3aa8fab893698e512f5851d19 (patch)
tree0a1fecba268201e271088ef4868bd2908681110a /configure.ac
parentc05c826bd18eedaa7720ff0817b5c796435dbc02 (diff)
use -g with --gdb-index in configure
It triggers an assert in mold's --gdb-index handling because of missing debug info. It sort of makes sense that --gdb-index should be tested with debug info actually used. Change-Id: I5adced29355deec9f0a6af390867f4ff2f2bd29c Reviewed-on: https://gerrit.libreoffice.org/c/core/+/134153 Reviewed-by: Ilmari Lauhakangas <ilmari.lauhakangas@libreoffice.org> Reviewed-by: Luboš Luňák <l.lunak@collabora.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6bd06894085f..d09359eea8b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4800,7 +4800,7 @@ if test "$enable_gdb_index" != "no"; then
if test "$enable_gdb_index" = yes -o \( "$test_gdb_index" = "yes" -a -n "$ENABLE_DEBUG$ENABLE_DBGUTIL" \); then
AC_MSG_CHECKING([whether $CC_BASE supports -ggnu-pubnames])
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror -ggnu-pubnames"
+ CFLAGS="$CFLAGS -Werror -g -ggnu-pubnames"
have_ggnu_pubnames=
AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[have_ggnu_pubnames=TRUE],[have_ggnu_pubnames=])
if test "$have_ggnu_pubnames" != "TRUE"; then