summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-06-16 16:21:08 +0200
committerMichael Stahl <mstahl@redhat.com>2017-06-16 16:56:42 +0200
commit3f405b1af38b810a6ae1089138637d7947ce4f82 (patch)
tree1aeab7b1b65c78c59ebbd1c83534aa7fbe823932 /configure.ac
parente5772fbc810a4c76da2a200db70e7acd776bc30b (diff)
configure: remove --enable-directx
This used to require extra SDKs in days of yore but now just always build those libraries on WNT. Change-Id: I92c0a35917df42e136c022c762f0333f657a9ec6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index f0c09476b7b2..c68105505bfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1116,13 +1116,6 @@ libo_FUZZ_ARG_ENABLE(evolution2,
enabled.])
)
-libo_FUZZ_ARG_ENABLE(directx,
- AS_HELP_STRING([--disable-directx],
- [Remove DirectX implementation for the new XCanvas interface.
- The DirectX support requires more stuff installed on Windows to
- compile. (DirectX SDK, GDI+ libs)])
-)
-
AC_ARG_ENABLE(avahi,
AS_HELP_STRING([--enable-avahi],
[Determines whether to use Avahi to advertise Impress to remote controls.])
@@ -3632,21 +3625,6 @@ MSPDB_PATH="$formatted_path"
AC_SUBST(MSVC_CXX)
AC_SUBST(SHOWINCLUDES_PREFIX)
-if test "$_os" = "WINNT"; then
- AC_MSG_CHECKING([whether to use DirectX])
- if test "$enable_directx" = "yes" -o "$enable_directx" = ""; then
- ENABLE_DIRECTX="TRUE"
- AC_MSG_RESULT([yes])
- else
- ENABLE_DIRECTX=""
- AC_MSG_RESULT([no])
- fi
-else
- ENABLE_DIRECTX=""
-fi
-
-AC_SUBST(ENABLE_DIRECTX)
-
#
# unowinreg.dll
#