summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-06-22 11:21:58 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-06-24 10:18:48 +0200
commit97794163dda8b08fb944e77d30f8fb98bfaa9f1b (patch)
tree2f90fed3ce1f48c42527e0efe988d670c48838bc /configure.ac
parent66839a21da8d552f2a66fe0b323f9cee7b05de80 (diff)
recent gcc versions also support -fuse-ld=lld
Change-Id: I0fd132965af051b6a717349943fa6827567c65dd Reviewed-on: https://gerrit.libreoffice.org/74557 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 87202bc17ea7..21061c96597b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3971,7 +3971,11 @@ if test "$enable_ld" != "no"; then
check_use_ld gold
fi
else
+ # For gcc first try gold, new versions also support lld.
check_use_ld gold
+ if test $? -ne 0; then
+ check_use_ld lld
+ fi
fi
ld_output=$(echo 'int main() { return 0; }' | $CC -Wl,-v -x c -o conftest.out - $CFLAGS $LDFLAGS 2>/dev/null)
rm conftest.out
@@ -3983,13 +3987,8 @@ if test "$enable_ld" != "no"; then
AC_MSG_RESULT([$ld_used])
if test -n "$ENABLE_DEBUG$ENABLE_DBGUTIL"; then
if echo "$ld_used" | grep -q "^GNU ld"; then
- if test -n "$COM_IS_CLANG"; then
- AC_MSG_WARN([The default GNU linker is slow, consider using the LLD or the GNU gold linker.])
- add_warning "The default GNU linker is slow, consider using the LLD or the GNU gold linker."
- else
- AC_MSG_WARN([The default GNU linker is slow, consider using the GNU gold linker.])
- add_warning "The default GNU linker is slow, consider using the GNU gold linker."
- fi
+ AC_MSG_WARN([The default GNU linker is slow, consider using the LLD or the GNU gold linker.])
+ add_warning "The default GNU linker is slow, consider using the LLD or the GNU gold linker."
fi
fi
else