summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-08-22 22:26:43 +0200
committerMichael Stahl <mstahl@redhat.com>2017-08-23 10:25:53 +0200
commitac3a4fe35e873de17eefb46c3f5e792aded6b0a5 (patch)
tree827cc2439380956e3b6413ca4717d2db06fef990 /configure.ac
parent9277cbcd691b484c3d746e2e9df9cc58544a1de2 (diff)
configure: try to keep PYTHON_VERSION from going stale
Since it was set to 3.5.0, the bundled python was upgraded twice, but the directory is still named python-core-3.5.0 :( Change-Id: I15eec4148c2436e1f289d9851ce5bd212d4a368a Reviewed-on: https://gerrit.libreoffice.org/41433 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fa0635647ae7..1cb18b284cf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8128,7 +8128,10 @@ internal)
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=5
- PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.0
+ PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.4
+ if ! grep -q -i python.*${PYTHON_VERSION} ${SRC_ROOT}/download.lst; then
+ AC_MSG_ERROR([PYTHON_VERSION ${PYTHON_VERSION} but no matching file in download.lst])
+ fi
AC_DEFINE_UNQUOTED([PYTHON_VERSION_STRING], [L"${PYTHON_VERSION}"])
BUILD_TYPE="$BUILD_TYPE PYTHON"
# Embedded Python dies without Home set