summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard PALO <richard@NetBSD.org>2015-09-15 15:58:51 +0200
committerNorbert Thiebaud <nthiebaud@gmail.com>2015-10-20 15:17:58 +0000
commitfd612a144c0028972513a18167a13d29326a1798 (patch)
tree66208cb56cc22e7d7b942f029a46f3213bb3a1a2 /configure.ac
parentd42c3e0ddd9078c00de591b7470d73ad8a186cb1 (diff)
Add DLOPEN_LIBS to configure for some cases where -ldl is needed
use std::sqrt in vcldemo.cxx Change-Id: I24d8ba15ee267d0cad3b063df9b7cfd8d284f4ee Reviewed-on: https://gerrit.libreoffice.org/18591 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5350de18aa1..be21c49e37db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -881,6 +881,15 @@ AC_SUBST(WITH_MINGW)
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)
+if test $_os != "WINNT"; then
+ save_LIBS="$LIBS"
+ AC_SEARCH_LIBS([dlopen], [dl],
+ [case "$ac_cv_search_dlopen" in -l*) DLOPEN_LIBS="$ac_cv_search_dlopen";; esac],
+ [AC_MSG_ERROR([dlopen not found in either libc nor libdl])])
+ LIBS="$save_LIBS"
+fi
+AC_SUBST(DLOPEN_LIBS)
+
###############################################################################
# Extensions switches --enable/--disable
###############################################################################