summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-02-20 18:12:51 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-02-20 21:19:26 +0100
commit358146bbbd1b9775c12770fb5e497b6ec5adfc51 (patch)
tree9fed9a97bed08973cab67ffd20398eae00d54255 /configure.ac
parentbe3de666fd452e5c9d61411ecd9d4815a99419b3 (diff)
Bump macOS build baseline to Xcode 11.3 and macOS 10.14.4
...as discussed at <https://lists.freedesktop.org/archives/libreoffice/2020-February/084471.html> "Bump macOS Xcode baseline to 11?" and <https://lists.freedesktop.org/archives/libreoffice/2020-February/084519.html> "ESC meeting minutes: 2020-02-20". (Code that might no longer be relevant will be cleaned up in follow-up commits.) Change-Id: I179e6099937d244502bd0e7fbff43f1734984213 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/89154 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0b728af2e5fb..77e4619f5022 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2858,10 +2858,10 @@ if test $_os = Darwin; then
my_xcode_ver1=$(xcrun xcodebuild -version | head -n 1)
my_xcode_ver2=${my_xcode_ver1#Xcode }
my_xcode_ver3=$(printf %s "$my_xcode_ver2" | $AWK -F. '{ print $1*100+($2<100?$2:99) }')
- if test "$my_xcode_ver3" -ge 903; then
+ if test "$my_xcode_ver3" -ge 1103; then
AC_MSG_RESULT([yes ($my_xcode_ver2)])
else
- AC_MSG_ERROR(["$my_xcode_ver1" is too old or unrecognized, must be at least Xcode 9.3])
+ AC_MSG_ERROR(["$my_xcode_ver1" is too old or unrecognized, must be at least Xcode 11.3])
fi
case "$with_macosx_version_min_required" in