summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-02-25 16:25:24 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-02-26 08:40:54 +0100
commit92df944f54696012963415111a706fca438e703b (patch)
tree4124e11e49d667e9f3371336a9abfea7f30f6165 /configure.ac
parent2cdaf50763b1d8e7f45c2e2d6cd93f29241e3f0c (diff)
Detect -std=c++20
at least Clang trunk accepts it now since <https://github.com/llvm/llvm-project/ commit/24ad121582454e625bdad125c90d9ac0dae948c8> "Add -std=c++20 flag, replace C++2a with C++20 throughout the Clang" Change-Id: I389bb2e79acbbdf2622dc7c839a3164836c40415 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/89464 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 973866050a4e..c9d75b19ecf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6563,7 +6563,7 @@ CXXFLAGS_CXX11=
if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
CXXFLAGS_CXX11='-std:c++17 -Zc:__cplusplus'
elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
- my_flags='-std=c++2a -std=c++17 -std=c++1z'
+ my_flags='-std=c++20 -std=c++2a -std=c++17 -std=c++1z'
for flag in $my_flags; do
if test "$COM" = MSC; then
flag="-Xclang $flag"