summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-02-15 16:36:37 +0100
committerStephan Bergmann <sbergman@redhat.com>2020-02-15 17:26:45 +0100
commitd0ca3064b05c477484c100c9d374b52d5e4ec454 (patch)
tree3ef3636050e1a766804d5c8dce59fb9326bad1d6 /configure.ac
parent54334d00f0aebf0e66a97b74d857136b4ee0b9af (diff)
IOBluetoothAddServiceDict is removed completely from MacOSX10.15.sdk
... (see Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/ MacOSX10.15.sdk/System/Library/Frameworks/IOBluetooth.framework/Headers/ IOBluetoothUserLib.h), so e.g. --with-macosx-sdk=10.15 --with-macosx-version-max-allowed=10.13 would have failed with > In file included from sd/source/ui/remotecontrol/BluetoothServer.mm:1: > sd/source/ui/remotecontrol/BluetoothServer.cxx:1477:19: error: use of undeclared identifier 'IOBluetoothAddServiceDict' > IOReturn rc = IOBluetoothAddServiceDict(reinterpret_cast<CFDictionaryRef>(dict), &serviceRecordRef); > ^ Change-Id: I520976c70ac0146953eb4d074e6e3d37a7cbffa1 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/88759 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e186f6d3eb73..d7237b8dc061 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10836,7 +10836,7 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
ENABLE_SDREMOTE=TRUE
AC_MSG_CHECKING([whether to enable Bluetooth support in Impress remote control])
- if test $OS = MACOSX && test "$MAC_OS_X_VERSION_MAX_ALLOWED" -ge 101500; then
+ if test $OS = MACOSX && test "$MACOSX_SDK_VERSION" -ge 101500; then
# The Bluetooth code doesn't compile with macOS SDK 10.15
enable_sdremote_bluetooth=no
fi